Android

Published on October 4th, 2012 | by Wira

0

Connection Issue on Xperia after Upgrade to Android 4.0 ICS

Sony Mobile has just release update software to Android 4.0 ICS for certain Xperia Android devices including Xperia S and Xperia Sola. The both Xperia devices get the update in different time but some users have been experienced with mobile and wireless connection to connect to Internet. We are still not sure if this kind of issue as the bug from the official Android 4.0 ICS for Xperia.

Xperia Sola user reported that they have experienced with data and MMS service where in previous version of Android OS work fine. Fixing the APN even though already follow the instructions that stated on the carrier is not useful because the problem still exist. However, for everything else except those two things is working.

release date xperia android smartphones upgrade to android ICS

While Xperia Arc S has problem with Wi-Fi connection, the problem happens after restart the phone once after the first reboot after upgrading to android 4.0 ICS finish. At the first boot after upgrade, the WiFi connection is normal like a charm. You can browse anything through your Wi-Fi but after restart the phone, the problem occurs.

A Xperia Arc S user just describing the problem as follow, when he try to connect to a WIFI-network, which has been encrypted with an WPA of WPA2 key, he can rarely get a stable connection. Usually it won’t connect at all. The home network is displayed with a strong signal on the list, but once he starts connecting, the signal drops to very weak. It keeps verifying and trying to connect but nothing happen. After some minutes he just aborts it and tries to do it all over again. Sometimes a reboot solves this problem, but once you’ve turned your Wi-Fi off and on again, you will have to reboot again.

In some rare occasions he gets an authentication error or he get connected with a very strong signal, but DNS lookup fails anyway. This is NOT related to his router. His phone worked perfectly with Gingerbread (Android 2.3.4) on any router. Now it doesn’t work (Android 4.0.4) on ANY router. Although the phone has FEWER problems on open networks, the problem with verifying occurs with almost every router he’ve tried (at home, work, friends, etc.)

Technical details:
Sony Ericsson Xperia Arc (LT15i)
SI 1246-1841
Android 4.0.4 (installed with Sony Update Service)
tested routers: Eminent EM4542 Wireless N

This shouldn’t be related to the routers. He hasn’t changed any settings on my router since the update to Ice Cream Sandwich. He already asks Sony’s tech support to have a look at this problem, because he sees he is not the only one. Perhaps is using an insecure network, downgrading to Gingerbread or trying another ROM (e.g. Cyanogen Mod) at the moment the best solution.

So, the solution for Xperia Sola may be the same like Xperia Arc S. It needs to confirm with others ROM like CyanogenMod or downgrading Xperia Sola to Android Gingerbread.

At the moment we don’t have any idea to resolve the problem since we don’t have enough resources to elaborate more methods to find out the root cause to resolve the Connection Issue on Xperia after Upgrade to Android 4.0 ICS.

Tags: , , ,


About the Author

Android enthusiast, tea lover but sometimes drink a cup of coffe, no smoking, and still trying to build own business.



Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Back to Top ↑